The BSA A7-A10 Forum

Technical => Clutch, Primary, Gearbox => Topic started by: TT John on 20.04. 2017 08:46

Title: Clutch problems
Post by: TT John on 20.04. 2017 08:46
I have been working on the A10 as I had a problem with the clutch, I found that I could not get any adjustment on it, so after dismantling the basket & making sure all was okay there, I checked the adjusting screw & nut, which I had difficulty in turning with a screwdriver, so out came the little dremal thing & I  managed to cut a better slot, then I noticed after getting the thing out that the ball which should be in the end was faulty, it had worn flat, which I thought was odd, I did have another complete screw & rod, in another spare box, which I have now fitted and I am hoping that is the last of my problems.
Quite a strange thing to happen, I thought considering that the ball in the end of the screw is hardened. Has anyone else come across this problem?

TTJohn
Title: Re: Clutch problems
Post by: KiwiGF on 20.04. 2017 09:52
I have seen the ball both seized and flattened in adjusters, and subsequently replaced them, the part is not too expensive, I suspect they get like that from use, I reckon the mod to have a 2 part pushrod with ball bearing in between would help them last, as hopefully the rod will never spin against the adjuster  *dunno*
Title: Re: Clutch problems
Post by: duTch on 20.04. 2017 09:57
 yep- had that for a while, and one day I might get a newie, but for now i just make sure the flat bit is on the pushrod,  figure that i can justify it with some kinda logic or B/S- seems to work ok (for now and a while back *eek*)

 not so easy for us over here to acquire simple little bits at reasonable price

** Kiwi GF rounded me up, mine spins freely I'm dubious about a ball int there, as I've seen the pushrod splayed. Maybe a ball in between two 1/4" rollers between the rods would be even better than just one roller of which I've always been an advocate.... *dunno*
Title: Re: Clutch problems
Post by: TT John on 20.04. 2017 12:56
I was thiinking about splitting the rod and sticking a 1/8" between but that will have to wait now until the next time I have trouble, I just thought it was worth mentioning this problem on the forum, to help others who may get the same symptoms. *smile*

TTJohn
Title: Re: Clutch problems
Post by: MartinK on 16.08. 2017 11:34
Is there not a ball bearing at the clutch end of the push-rod?
Title: Re: Clutch problems
Post by: morris on 16.08. 2017 20:57
Is there not a ball bearing at the clutch end of the push-rod?
Nope. SRM does sell a clutch side adjuster with a thrust bearing but I am not sure it'll fit the standard setup or you need to go the whole way and install one of their pressure plates also.
Maybe someone who did the conversion can confirm?
Title: Re: Clutch problems
Post by: scotty on 16.08. 2017 21:39
Without major modification to the original pressure plate the SRM needle roller lift assy will not work so you'll need the SRM pressure plate as well which has the adjuster built into it

I think the SRM pressure plate only works with 4 spring clutch

I have this set up on both my A & B series

IMHO both are a great clutch upgrade

S