The BSA A7-A10 Forum

Technical => Clutch, Primary, Gearbox => Topic started by: a101960 on 07.09. 2017 19:37

Title: Clattering noise
Post by: a101960 on 07.09. 2017 19:37
Well, today I managed to get my clutch reassembled, it has a nice light one finger action, but there is a puzzeling problem. When I pull the clutch lever in and disengage the clutch and turn the clutch over using the kick start pedal there is what I can best describe as a clatterring noise. It sounds like the plates are loose and are flapping about. With the clutch engaged the engine turns over fine, and the clutch does not slip. When the clutch is disengaged there is no drag and the engine does not turn over when operating the kick start pedal so everything is working just as it should. Thinking that something might be dreadfully wrong, I took it all apart again and I could find nothing wrong. Any suggestion as to what could be happening? I have changed no parts other than the springs these were changed because the originals were all different lengths. As I say the clutch appears to work just fine except for that rattle noise.
John
Title: Re: Clattering noise
Post by: JulianS on 07.09. 2017 19:46
Could be the tabs on the plates rattling in the slots in chainwheel and hub?
Title: Re: Clattering noise
Post by: Greybeard on 07.09. 2017 22:34
Get a well fitting helmet?
Title: Re: Clattering noise
Post by: jachenbach on 08.09. 2017 00:58
Ducati riders LOVE that noise! *smile*
Title: Re: Clattering noise
Post by: cyclobutch on 08.09. 2017 08:27
Ducati riders LOVE that noise! *smile*

My Griso clutch was noisy enough to scare Ducati riders.