The BSA A7-A10 Forum

Technical => Lucas, Electrical, Ignition => Topic started by: edboy on 07.11. 2018 20:09

Title: gutless k2f
Post by: edboy on 07.11. 2018 20:09
i have a k2f that had been overhauled and reconditioned a decade ago but now is giving me problems. it ticks over but gutless, breaks down on acceleration. poor spark. it must be the armature as i ve swopped everything over with a good working maggie.
rewind or condensor? i ve only done about 4,000 miles on this one and everything looks brand new.
Title: Re: gutless k2f
Post by: chaterlea25 on 07.11. 2018 20:15
Hi Ed
That sounds like a faulty condenser,  *????* There were some crap slip rings around too  *ex*

John
Title: Re: gutless k2f
Post by: edboy on 07.11. 2018 20:19
thanks for reply john.
that would be the easiest fault to cure as i have an easy cap condensor here. the slip ring is new and i ve belled out continuity.
Title: Re: gutless k2f
Post by: duTch on 07.11. 2018 21:00

 I recently had an issue with mine, that had a very tiny hole burn through from the slip-ring and was shorting to the armature....Slip ring only replaced a year or so ago, only done a couple thousand miles- have a really close look at it if the easy cap doesn't fix it
Title: Re: gutless k2f
Post by: edboy on 07.11. 2018 21:30
ok dutch. when i strip the mag i will take a close look.
Title: Re: gutless k2f
Post by: duTch on 07.11. 2018 21:40

 PS- was a brand new slip-ring too, a white one from England...
Title: Re: gutless k2f
Post by: trevinoz on 07.11. 2018 22:11
Those little holes are hard to see!!
I've also had one but mine was a black one.
Title: Re: gutless k2f
Post by: bsa-bill on 07.11. 2018 22:25
are you talking about a different tiny hole than the one for a lubrication wick
Title: Re: gutless k2f
Post by: duTch on 07.11. 2018 22:33

 
Quote
  are you talking about a different tiny hole than the one for a lubrication wick 

 I think so Bill- I'm cranky that I didn't end up with the S/R to take a photo, but was a burn hole no bigger than pin-prick size (if that) in the 'armature interface surface' of the white slip-ring, can only be seen disassembled
Title: Re: gutless k2f
Post by: lawnmowerman on 07.11. 2018 23:59
Hi Ed

I had very similar problems on a K2F that was only rewound about five years ago. Turned out to be soft carbon brushes which left a coating of carbon around the slip ring and cheapo pick-ups.
Cleaned up the slip ring and fitted decent brushes and pick-ups from Brightspark and it feels like a different bike.

Jim
Title: Re: gutless k2f
Post by: Triton Thrasher on 08.11. 2018 07:16
are you talking about a different tiny hole than the one for a lubrication wick

The cam ring has a hole for a lubrication wick.

The cam ring is not the slip ring.
Title: Re: gutless k2f
Post by: bsa-bill on 08.11. 2018 11:01
Quote
The cam ring is not the slip ring.

you right TT, I misread somewhere