The BSA A7-A10 Forum

Technical => A7 & A10 Engine => Topic started by: taroha10 on 29.06. 2010 19:15

Title: In and out play in speedo drive pinion
Post by: taroha10 on 29.06. 2010 19:15
I seem to have alot of in and out play in the speedo drive pinion ( maybe 2mm ) when just the inner gearbox cover is in place.I have checked to see if there is a thrust washer behind the pinion, which there is,but this ammount of play doesn't seen right to me.
Cheers.
Title: Re: In and out play in speedo drive pinion
Post by: dpaddock on 29.06. 2010 20:06
Welcome to The Forum.
     One of our rules of etiquette is to state the year and model of your A7/A10 when posting. This gives us a better chance to help answer your questions.
     Guessing you have the A10, the end play you state is OK, regardless of its vintage..
Cheers,

David
Title: Re: In and out play in speedo drive pinion
Post by: muskrat on 29.06. 2010 21:18
G'day Taroha, welcome,
                                      I have the same on my '51 A7, about 1.25mm. I have tried temporary shims at either and both ends of the lay shaft and found no difference in operation. If all the bits are where they are meant to be the wear on the bushes are to blame. If it all works ok leave it, if not fix it.
Cheers
Title: Re: In and out play in speedo drive pinion
Post by: taroha10 on 04.07. 2010 22:22
Thanks loads for the replys.Sorry I forgot to put down model year etc.(1960 Super Rocket).Have never used a Forum before and am amazed at the Quick responce.Finally got back to shed today,many jobs to do,gearbox next.Thanks again! Taroha10.
Title: Re: In and out play in speedo drive pinion
Post by: Rusty nuts on 07.07. 2010 11:35
On a semi unit plunger box you just remove the kickstart quadrant from the outer case place a suitable drift on the small bush (not the pinion) & give it a sharp tap.
How long before the bush moves again is another matter  *smile*

Rusty