The BSA A7-A10 Forum

Technical => Lucas, Electrical, Ignition => Topic started by: a10sausage on 05.12. 2010 12:18

Title: manual advance/retard k2f magneto problem
Post by: a10sausage on 05.12. 2010 12:18
Hi folks
         I am sure somebody out there can help me, i have purchased manual advance retard magneto that was previously on a super rocket for my 1958 650 flash as my original mag failed with collapsed bearings...the mag was rebuilt about a year ago and has a good spark when rotated by hand.
  Now for the problem...the manual advance retard does not work,i thought the way these mags work is by rotating the cam ring by 15% but there is no movement when i pull or push on the cable the mechanism seems solid...i am new to these manual mags...can the forum help !
i can supply pics.
Title: Re: manual advance/retard k2f magneto problem
Post by: tombeau on 05.12. 2010 13:55
Can the ring turn freely in the body? pull the ring out, and have a look at it. Could be dirty, or the ring or body could be distorted.  If its a new ring it could have been made too tight a fit.
Is the cable nipple sitting in the groove properly?
Cheers,
Iain
Title: Re: manual advance/retard k2f magneto problem
Post by: a10sausage on 05.12. 2010 15:30
hi it looks like the ring is locked by a screw stop at the bottom of the cam ring and is not siezed..i wonder if the cam ring is in upside down, the larger gap sits at the top of the mag..there is a brass screw that can wound down here as well...thanks to all on the forum
Title: Re: manual advance/retard k2f magneto problem
Post by: chaterlea25 on 05.12. 2010 16:25
HI, A10
Yup it looks as if the camring is in upside down!!!!!
The slot should be at the bottom, the peg limits the travel
They can be weird to the uninitiated *ex*
The cable end fitting should fit into a slot on the outside of the ring to turn it
Its very easy for the ring to move outwards a little and lose connection with the cable fitting *eek*
Its the end cover which holds the camring  in place,
It looks like your mag has the bakelite type end cover, (not screw on) some pattern ones of these dont hold in the camring in place properly  *sad2*
They can be modded to make them work correctly

HTH
John O R
Title: Re: manual advance/retard k2f magneto problem
Post by: dpaddock on 05.12. 2010 16:38
John OR is correct, as usual. The K2F mag was fitted with either of two cam rings: Lucas p/n 459130 for the auto advance and having a single notch, and 458725 for the manual advance having a wider notch plus a slot for the plunger.

David
Title: Re: manual advance/retard k2f magneto problem
Post by: a10sausage on 05.12. 2010 17:55
fantastic result folks, its just as you said the cam ring was on upside down....now working great !

thanks for the help.
now to buy a new cable as the on the mag is worn.