The BSA A7-A10 Forum

Technical => A7 & A10 Engine => Topic started by: clive f on 23.07. 2011 17:53

Title: Won't start when hot
Post by: clive f on 23.07. 2011 17:53
Hi everyone I have now successfully put together my forks and the A7 has now got an mot, however there is a problem, the bike is an easy starter when it is cold but the longer you ride it the less it wants to idle and if the motor stops it is a pig to start. I am thinking it is a carb problem.

Any thoughts out there?
Title: Re: Won't start when hot
Post by: A10Boy on 23.07. 2011 18:04
Yes, either too rich or the mag is faulty. They can fail when hot, the windings break down or the condenser packs up. The problem is, that if you take a plug out to check the spark, it can spark because its not under compression. Try closing the gaps next time it happens. Do the plugs look like its running rich?
Title: Re: Won't start when hot
Post by: muskrat on 23.07. 2011 21:51
G'day Clive,
                most home tuners (and some shop ones) don't bring the bike up to full operating temp before adjusting the pilot and idle. It should take a good 10 minute ride before setting them. So if you can get that part right and it plays up later it points towards the mag as Andy suggests.
Cheers
Title: Re: Won't start when hot
Post by: Goldy on 23.07. 2011 22:20
Have you got a thick insulating gasket between the carb and the head, because if not heat can be transferred to the carb body and cause the type of problems that you refer to.
Title: Re: Won't start when hot
Post by: clive f on 23.07. 2011 22:27
Cheers guys this is good, I now hav lots to check and tryout to get the bike running right.
Title: Re: Won't start when hot
Post by: robroy on 22.01. 2012 13:39
Hi Clive
Did you get to the bottom of this?

My A10 displays identical symptoms very frustrating, mine also feels like it loses power as it warms up

Cheers

Rob
Title: Re: Won't start when hot
Post by: renos-a10 on 22.01. 2012 17:46
 G'day all

 My opinion is magneto.My A10 had the same problem and i send in england for recondition.The problem solved.

Cheers
Title: Re: Won't start when hot
Post by: beezermacc on 22.01. 2012 18:36
Robroy - I've sent you a PM - hope this helps.
Title: Re: Won't start when hot
Post by: jfligg on 22.01. 2012 22:49
Hey Have you checked to see what your not getting when its hot?  Are you loosing spark?  What do the plugs look like?  Have a look at the points on the left side of the mag.  Good Luck Jeff
Title: Re: Won't start when hot
Post by: Felters on 15.02. 2012 21:04
Somebody a lot smarter than me once said that 80% of all carb problems are electrical. I'd bet you £5 to a bag of conkers that the mag is knackered.
Title: Re: Won't start when hot
Post by: wilko on 15.02. 2012 21:12
Somebody also said most mag problems are carby faults! Hope that helps??