The BSA A7-A10 Forum

Technical => Clutch, Primary, Gearbox => Topic started by: orabanda on 21.09. 2014 11:39

Title: Why gear change locked up
Post by: orabanda on 21.09. 2014 11:39
Life = learning!
Re-building a plunger gearbox; when the middle cover was fitted the gear change locked up. Also, the rod that the selector forks slide along, was difficult to fit.

The reason for my problems proved to be my failure to use a gasket under the pivot pin for the camplate. I had only used loctite sealant. This loaded  the cam plate  against the two selector forks.
Pulled another spare gearbox apart, and found the gasket under the pivot pin was about 0.040", so cut and fitted a gasket of that amount. I also spun the selector fork rod in the lathe and found that there was a slight wobble below the rebate for the retaining grub screw. A couple of light taps with a copper hammer brought it back to running true.

Re-assembled box and, by the great measurements of Sabrina, it now shifts beautifully! (and the rod slides into position with a light push).

In future, I will check that there is at least 0.040"gasket under the pivot pin plate.

Richard
Title: Re: Why gear change locked up
Post by: duTch on 22.09. 2014 22:36

 I played recently with my spare box and considered that, but somehow determined clearance as I also have a slightly bent shaft.
   Maybe I determined the position of the shaft in the inner cover with the cover off but otherwise fully assembled and checked for clearance, inner cover off. OR, partly assembled with camplate, shaft, forks and inner  cover, and roll it over slowly to see if it rattled *eek*....a but haphazard I know, but is a bit hard to see what goes on in there otherwise....

N if this comes out weird, is 'cos I'm on the phone..!