Author Topic: Auto advance stuck and mag has issues  (Read 1134 times)

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #15 on: 26.06. 2017 11:14 »
No wiggle on the armature that I can detect. It was rebuilt as recently as April and I am sending back to let the well renowned Andrew at Priory magneto's to cast his expert eye over. He is very good he has done a few rebuilds on dynamo's for me to a very high level.

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1085
  • Karma: 18
    • www.brightsparkmagnetos.com
Re: Auto advance stuck and mag has issues
« Reply #16 on: 26.06. 2017 11:55 »
Problem solved then. Good plan! Summat funny must have happened then, as it certainly wouldn't have been like that when Andrew had done with it.
Bill

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #17 on: 26.06. 2017 12:37 »
I know but recently I have had the DVR2 regulator fail,perhaps I am waiting to hear, they never fail. Since I rebuilt the engine/dynamo/magneto and carb I have never had some many issues. It was more reliable when it consumed more oil than petrol.

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #18 on: 02.07. 2017 21:16 »
Magneto is repaired and on its way back. Andrew said the play wasn't too disastrous back the probelm starting was because the points had shut closed??. Never touched them so how?. Also some tracking along the slip ring. So he has worked his magic and has sent it back to me. 

Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1510
  • Karma: 20
Re: Auto advance stuck and mag has issues
« Reply #19 on: 03.07. 2017 14:46 »
Points gaps have to be checked and adusted.

It's maintenance.

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #20 on: 03.07. 2017 15:18 »
The mag had only been on the bike for a month or so and only 200 miles done. In the 27 years I have owned this bike it was generally a once a year job and even then they hadn't changed. So wasn't really looking to that as the reason behind the bikes difficult starting.

Offline Bsareg

  • Valued Contributor
  • ****
  • Join Date: Mar 2016
  • Posts: 282
  • Karma: 2
Re: Auto advance stuck and mag has issues
« Reply #21 on: 03.07. 2017 15:49 »
If they are new points then they settle down and bed in
C11,B40,B44 Victor,A10,RGS,M21,Rocket3,REBSA

Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1510
  • Karma: 20
Re: Auto advance stuck and mag has issues
« Reply #22 on: 03.07. 2017 15:58 »
Next time a bike won't start, check plugs first, then points.

I notice you checked timing in Post #1. That would have been a godd time to check the gap.

Not trying to annoy you.  Bet it won't catch you out again.

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #23 on: 03.07. 2017 16:23 »
Yeah did all the usual checks and at first no spark, then they returned rinse and repeat. Andrew did say there were a few issues so he replaced the slip ring/armature and pick up brushes just to be sure. He does a very good job. I was mislead into thinking it was fuel first off as the mag was only a couple of months post rebuild. We all miss the obvious if we don't look ;). I got led off piste with the points when I noticed the armature play and of course fixated on it

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 705
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Auto advance stuck and mag has issues
« Reply #24 on: 09.07. 2017 13:49 »
Mag back in starts first kick and ticks over as it should. There was a horrible noise first start, turned out the fibre gear was too tight  to the cam gear, a quick mounting bolt wiggle sorted that. Andrew did another great job with his skills etc around mags and also dynamo's.

Offline beezermacc

  • Wise & Enlightened
  • *
  • Join Date: Dec 2011
  • Posts: 1010
  • Karma: 39
  • Not for the purist!
    • Priory Magnetos Ltd.
Re: Auto advance stuck and mag has issues
« Reply #25 on: 10.07. 2017 06:52 »
Thanks for your kind remarks.
Priory Magnetos Ltd - A10 spares, magneto and dynamo refurbs. www.priorymagnetos.co.uk