Author Topic: Can ignition timing go faulty during use?  (Read 1640 times)

Offline Swarfcut

  • Resident Legend
  • *****
  • Join Date: Oct 2018
  • Posts: 706
  • Karma: 9
Re: Can ignition timing go faulty during use?
« Reply #75 on: 07.05. 2019 09:17 »
 Owain...    At last, a bit of good news.  A contributing fault identified and the answer to the title of this topic. YES IT CAN!

 By all accounts the magneto is generating sparks but not necessarily at the right time, and the reason why is now clear. Looking back at this saga, the answer was there from the start. 

 So for now I would clean up the mating surfaces, even a vestige of the key should be enough to locate it. If it is smoothed off completely try a small drilling and a soft brass or copper locating peg. Just big enough  to locate the plate, but not too big to bottom on the internal slot on the armature taper. As groily says, the drive is transmitted by the taper, and the bolt needs to be reasonably tight for the taper to grip, but not murder tight. Tapers too loosely tightened are the main cause of keyway damage and sheared keys, typically as seen on gearbox mainshaft/clutch centre tapers.

  Another problem may be that the internal taper on the armature has been spread, resulting in rock on the points plate, and consequent inconsistent points gap (and varied timing) between the cylinders.
   What I am suggesting is to reassemble with what you have to establish whether the magneto is capable of sparking at the right time, before spending more cash on what may prove to be a shagged  armature. A bit of a temporary and maybe unreliable fix, but to just get it running again. For future serious use I still consider a Thorspark System is your cheapest long term option. You may spend up to 25% of this cost just for a set of well used points on a questionable backing plate.

 Brass contact plates and later steel backed versions interchange, but each requires its own specific retaining bolt.

 Swarfy.

 

Online duTch

  • Ricketty Rocketty Golden Flashback
  • Wise & Enlightened
  • *
  • Join Date: Oct 2011
  • Posts: 4444
  • Karma: 40
Re: Can ignition timing go faulty during use?
« Reply #76 on: 07.05. 2019 09:43 »

 Without going back to read the whole story, is it possible to try a known good maggie to see i how it goes ?
Started building in about 1977/8 a on average '52 A10 -built from bits 'n pieces never resto intended -maybe 'personalised'
Have a '74 850T Moto Guzzi since '92-best thing I ever bought doesn't need a kickstart 'cos it bump starts sooooooooo(mostly) easy
Australia

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1034
  • Karma: 17
    • www.brightsparkmagnetos.com
Re: Can ignition timing go faulty during use?
« Reply #77 on: 07.05. 2019 14:50 »
To Swarfy's point, yes - it should be poss to get the cb on in pretty well the right spot even without a proper register, to see how it does, even if only temporarily.
If it was miles off position from the get-go, you'd have had no / very weak sparks because the internal timing won't tolerate a truly massive error. But if when freshly assembled all seemed well, and then it went off, could be the cb unit had gone walkabout from a correct starting position, and moved enough - within the capacity of the mag still to spark after a fashion - to mess up the ignition point.
Sounds as if you'd maybe get to happy if the keyway could be recreated by one of the methods mentioned  . . . worth a go, anyway.
Bill

Offline owain

  • A's Best Friend
  • ***
  • Join Date: Mar 2017
  • Posts: 127
  • Karma: 2
Re: Can ignition timing go faulty during use?
« Reply #78 on: 23.07. 2019 22:13 »
As a follow-up to all the advice given and all problems with ignition, the motorcycle has been running well again. APL magnetos were kind enough to replace the contact breaker assembly that after using fine grit sand paper to give the point a very thorough clean; the bike started straight away. It appears that my problem may have initially been due to dirty points on the magneto. Although they allowed for some electrical discharge from the spark (enough to light up my cheap spark plug indicator) the connection between the points wasn't good enough to allow enough voltage to jump the spark plug gap. As for the broken fin on the contact breaker assembly, it's difficult to know whether this was broken before hand contributed to my initial problems or whether it broke due to my heavy handedness. Either way, once it was replaced and magneto points cleaned it worked fine!

Huge thanks to everyone for their input!
Sweden & North Wales
'50 BSA A10
'69 BSA A75R

Online Greybeard

  • Jack of all trades; master of none.
  • Wise & Enlightened
  • *
  • Join Date: Feb 2011
  • Posts: 5552
  • Karma: 29
Re: Can ignition timing go faulty during use?
« Reply #79 on: 24.07. 2019 10:13 »
Good news!