Author Topic: electronic ignition faling  (Read 145 times)

Offline Guy Wilson

  • Valued Contributor
  • ****
  • Join Date: Feb 2011
  • Posts: 266
  • Karma: 1
electronic ignition faling
« on: 31.05. 2020 08:04 »
I have a Boyer Mk111 ignition system on my Triumph TR6P. Has anyone had any experiencing of these failing and if so how they fail? I was riding last week and had problems with the clutch.. - the engine was running fine..having sorted the clutch, I only managed 200 yards before it stopped and backfired badly like a gun shot and refused to start. I cleaned the plugs about 30 minutes later and it started fine, revved etc.. My experience of electronic ignitions is when they fail, they do completely...
It feels like a carb issue. the bike has been laid up for a couple of years and is only recently back on the road and is in a shakedown period... any advice?
Many thanks
Guy
Good Advice
0
No reactions

beezermacc

  • Guest
Re: electronic ignition faling
« Reply #1 on: 31.05. 2020 08:37 »
I think you may have unwittingly dipped into the wrong forum!
Good Advice
0
No reactions

Online Rex

  • Resident Legend
  • *****
  • Join Date: Apr 2017
  • Posts: 617
  • Karma: 2
Re: electronic ignition faling
« Reply #2 on: 31.05. 2020 08:39 »
I've had a couple act like that, but the problem was actually low battery voltage through charging issues rather than the EI units themselves. The clue here is in the sentence "thirty minutes later.." after which time the battery will have recovered slightly.
Going on to one cylinder and badly misfiring were the other symptoms.
Good Advice
0
No reactions

Online Butch (cb)

  • Wise & Enlightened
  • *
  • Join Date: Aug 2010
  • Posts: 1560
  • Karma: 14
Re: electronic ignition faling
« Reply #3 on: 01.06. 2020 11:14 »
I always presumed that solid state stuff would fail instantly and catastrophically. However, on my Guzzi V50 (seeing as we're on a non A7/A10 thread here) which has electronic ign as OE went intermittent before finally failing.  A replacement (second hand) unit fixed it.
Good Advice
0
No reactions
Warning - observations made by this member have a 93% unreliability rating.

Of Bikes; various, including ...
'58 Iron Head Flash Bitza


Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1542
  • Karma: 20
Re: electronic ignition faling
« Reply #4 on: 01.06. 2020 18:48 »
Quote from: Rex
the problem was actually low battery voltage through charging issues

Easily tested too.
Good Advice
0
No reactions