Author Topic: E3L Dynamos with no output  (Read 158 times)

Online Roger (Doomtrainbarx)

  • A's Good Friend
  • ***
  • Join Date: Jun 2020
  • Posts: 62
  • Karma: 0
    • Soundclick
E3L Dynamos with no output
« on: 10.05. 2021 14:27 »
I had 2 dynamos - neither worked - turned out to be just dirty brushes - quick emery-up and I now have 2 fully functioning dynamos !!  -- Unbelievable it was as simple as that .
1961 Super Rocket
1962 Super Rocket
2003 Kawasaki Z1000
1987 Kawasaki ZL1000 Eliminator
1989 Harley FXRS (Turbo)
1978 Triumph T140 Bonneville

Online Minto

  • Valued Contributor
  • ****
  • Join Date: Mar 2019
  • Posts: 467
  • Karma: 4
Re: E3L Dynamos with no output
« Reply #1 on: 10.05. 2021 18:19 »
Epic win, as the kids say nowadays.
52 A10 plunger
Aprilia RSVR

Online KiwiGF

  • Last had an A10 in 1976, in 2011 it was time for my 2nd one. It was the project from HELL (but I learned a lot....)
  • Wise & Enlightened
  • *
  • Join Date: Feb 2011
  • Posts: 1614
  • Karma: 13
Re: E3L Dynamos with no output
« Reply #2 on: 10.05. 2021 21:32 »
I had 2 dynamos - neither worked - turned out to be just dirty brushes - quick emery-up and I now have 2 fully functioning dynamos !!  -- Unbelievable it was as simple as that .

I had a similar experience, I got the dynamo working and a few hundred miles later it stopped working, cleaned the brushes and the same happened again, despite it passing the usual “join wires” test (on a drill). The solution was new brushes, the old brushes looked ok but must have gone soft or something and they caused enough resistance after relatively few miles to stop the dynamo’s “self start” capability at low revs, but otherwise the dynamo resistances checked out ok. Had me  *eek* *eek* for a while.
New Zealand

1956 A10 Golden Flash (1st finished project)
1949 B31 rigid “400cc” (2nd finished project)
1968 B44 Victor Special (3rd project,in progress)
2001 GL1800 Goldwing, well, the wife likes it
2007 KTM 950 Adventure, cos it’s 100% nuts