Author Topic: Odd running on a closed throttle  (Read 235 times)

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Odd running on a closed throttle
« on: 28.04. 2021 13:16 »
Not sure this is a carb issue but I will start with that. When riding bike runs really well when engine is under load no issues starts well,ticks over etc etc. But it has always(and I mean for years and years) pops,hesitates runs not smoothly, difficult to explain, with the throttle closed or backed off. The list of checks etc etc...
1. No visible air leaks around the carb or exhausts
2. Mag always starts well and timed with the timing buzzer
3. No head leaks
4. Last couple of years the carb resleeved/engine rebored/head new valves etc

As I said I have owned this bike many years (30+) and it has always done this. Am I expecting to much and is this a case of they all do that sir

Offline Swarfcut

  • Wise & Enlightened
  • *
  • Join Date: Oct 2018
  • Posts: 1467
  • Karma: 25
Re: Odd running on a closed throttle
« Reply #1 on: 28.04. 2021 14:44 »
 Popping back in the Silencer on the over run was a sign of a weak mixture. Try raising the  throttle needle as a first try.

 Swarfy.

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Odd running on a closed throttle
« Reply #2 on: 28.04. 2021 15:07 »
Cool thanks I shall try that

Online chaterlea25

  • Wise & Enlightened
  • *
  • Join Date: Jun 2009
  • Posts: 3500
  • Karma: 49
Re: Odd running on a closed throttle
« Reply #3 on: 28.04. 2021 23:09 »
Hi,
What carb is fitted?
Recently while trying to sort out an A10 that was "acting the maggot" I found that the jet block had come loose in the carb body, (monobloc)
A worn needle jet / needle or a "T" needle jet (2 stroke) will also cause problems

John


1961 Super Rocket
1963 RGS (ongoing)

Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1606
  • Karma: 20
Re: Odd running on a closed throttle
« Reply #4 on: 29.04. 2021 06:42 »
Richness at small throttle openings, such as is caused by a worn needle jet, can cause symptoms that vaguely match your vague description.

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Odd running on a closed throttle
« Reply #5 on: 29.04. 2021 10:10 »
Richness at small throttle openings, such as is caused by a worn needle jet, can cause symptoms that vaguely match your vague description.
Trust me I wish I could be less vague *smile*
In reply to others its a 1 inch 376 monobloc, resleeved a couple of years ago(no play in slide) 25 pilot,1065 jet(new couple years ago) position 3 on the needle clip. MAIN i THINK IS A 240. Its a alloy head with 8:1 compression recent new valves/guides/rebore big ends etc etc

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Odd running on a closed throttle
« Reply #6 on: 29.04. 2021 10:11 »
Oh its a 'c' needle

Online berger

  • Wise & Enlightened
  • *
  • Join Date: Nov 2017
  • Posts: 1578
  • Karma: 9
  • keith.uk 500sscafe.norbsa project,honda 750fz
Re: Odd running on a closed throttle
« Reply #7 on: 29.04. 2021 10:45 »
do you mean it runs odd when just on tick over as in touching nothing stood back listening to it's odd running or the very first bit of throttle opening. also if it is when touching nothing is it on side stand or centre stand or slung up against a wall, as I used to do and I bet most others have too ;)

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Odd running on a closed throttle
« Reply #8 on: 29.04. 2021 11:13 »
No when riding and you are slowing/coasting with throttle closed/part open. Just popping/not running clean etcetc

Online Angus

  • Suffolk, UK
  • Resident Legend
  • *****
  • Join Date: Nov 2012
  • Posts: 539
  • Karma: 11
  • The A7
Re: Odd running on a closed throttle
« Reply #9 on: 29.04. 2021 13:04 »
My A7 (to SS spec with open goldie silencers) has always done this (pop and bangs from the exhaust), back when I was 17 I loved it. But two rebuilds (last one by Roger at Cake street classics) and two carbs, plus lots of other changes over the years it still does it. She runs slightly rich. ps I still like it doing it as it brings back good memories.
1961 A7 since 1976
1960 A10 Gold Flash Super Profile Bike
1958 Matchless G80 Project
1952 Norton Model 7 Plunger
1950 T100

Offline BSA500

  • Resident Legend
  • *****
  • Join Date: Dec 2007
  • Posts: 725
  • Karma: 4
  • Tonbridge,Kent,UK
Re: Odd running on a closed throttle
« Reply #10 on: 11.05. 2021 13:35 »
Small update put some Denso plugs in and running a lot more even but plug look a little sooty/black