Author Topic: M20 won't start, No fuel at plug! ?!  (Read 967 times)

Offline Big Seven

  • Moving Up
  • **
  • Join Date: Jun 2013
  • Posts: 22
  • Karma: 0
M20 won't start, No fuel at plug! ?!
« on: 19.08. 2015 18:48 »
I know this forum deals with A10/7's but my M20 needs love too. I cannot understand why although my carb is full of fuel, no matter how much I choke , open the throttle and kick it over, the plug stays dry. I have a new main jet and have replaced the exhaust valve. It's a 376 amal with a bell mouth, any ideas ?

Offline unclerob

  • A's Good Friend
  • ***
  • Join Date: Jul 2012
  • Posts: 218
  • Karma: 7
Re: M20 won't start, No fuel at plug! ?!
« Reply #1 on: 19.08. 2015 19:13 »
Pilot jet corroded and blocked because of ethanol in the petrol I'd guess!

Offline morris

  • Wise & Enlightened
  • *
  • Join Date: Aug 2012
  • Posts: 1771
  • Karma: 27
  • Antwerp, Belgium
Re: M20 won't start, No fuel at plug! ?!
« Reply #2 on: 19.08. 2015 20:53 »
I assume it won't fire either? I'd have a look at the ignition first. It's known that although a plug sparks outside the cylinder, it sometimes fails to spark under pressure if the magneto's on his way out.
A plug doesn't necessarily has to be "wet" to show that there's fuel in the combustion chamber.
'58 BSA A 10 SA
'52 BSA A 10 Plunger
'55 MORRIS ISIS
The world looks better from a motorbike
Belgium

Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1952
  • Karma: 23
Re: M20 won't start, No fuel at plug! ?!
« Reply #3 on: 19.08. 2015 21:33 »
Put a small amount of petrol in through the spark plug hole.

Offline Big Seven

  • Moving Up
  • **
  • Join Date: Jun 2013
  • Posts: 22
  • Karma: 0
Re: M20 won't start, No fuel at plug! ?!
« Reply #4 on: 20.08. 2015 12:21 »
Thanks for your replies, I can see this is not as simple as I'd hoped. Will have to have Mag checked, carb is ok I believe. Bike starts ok when bumped so mag seems likely culprit!

Offline Rocket Racer

  • Wise & Enlightened
  • *
  • Join Date: Jun 2009
  • Posts: 1670
  • Karma: 17
  • A kiwi with a racing A10 rig and too many projects
    • NZ Classic Sidecar Racing
Re: M20 won't start, No fuel at plug! ?!
« Reply #5 on: 21.08. 2015 00:04 »
Appreciate this insnt a beesa preunit singles forum, the damn things are typically too reliable to need one  ::hh::
Yes typically the mag is 1st point of attention, take the plug out, hold it against the head and do you get a nice big fat spark?
Also put your finger over the plug ole and confirm you've got compression, if not tappets might be tight or you new valve seat not sealing (so not sucking the juice through).
I owned an M, great bikes, tough as old boots, especially the pre 48 girder jobs.
keep us informed and please post a picture of the bike.
 
A good rider periodically checks all nuts and bolts with a spanner to see that they are tight - Instruction Manual for BSA B series, p46, para 2.
New Zealand