Author Topic: ignition timing question, help needed  (Read 358 times)

Offline tonyairconchap

  • Moving Up
  • **
  • Join Date: May 2018
  • Posts: 22
  • Karma: 0
ignition timing question, help needed
« on: 17.08. 2018 22:12 »
Hi All,  i have today received my reconditioned mag.  Been all night trying to set up the timing.
got a few questions to ask if anyone could give me answers i will be very greatful.
I am ok with single cylinder engines as its impossible to get it wrong but this is the first twin i have attempted.

1)  which spark plug lead goes to the rear pickup (  gearbox side ),  left or right cylinder? Cant remember how i took then off.
2) which cylinder fires first, looks like its the right hand side  as thats the one that comes to tdc first. So which pick up point would go to that one?
3)  do i set the timing with the lead cylinder only?
4) do i set the auto advance unit in the fully relaxed state when setting the timing? 
5) do the points open and close twice in a 360 degree cycle? If so how do i know which opening point is the one for the lead cylinder as i assume this is the one i set the timing up on.

If i have things wrong, let me know,  put me right please.

Cheers for now, tony


Offline tonyairconchap

  • Moving Up
  • **
  • Join Date: May 2018
  • Posts: 22
  • Karma: 0
Re: ignition timing question, help needed
« Reply #1 on: 17.08. 2018 23:05 »
I just found an answer to my question 4, the auto advance unit is normally in a retard position at rest, so i need to wedge it fully open to fully advanced state  to set the timing.  So thats one of my questions answered.  ( found this deep in the forum,  know doubt all the other answers are there also , so will keep looking )
Tony

Online Greybeard

  • Jack of all trades; master of none.
  • Wise & Enlightened
  • *
  • Join Date: Feb 2011
  • Posts: 5683
  • Karma: 30
Re: ignition timing question, help needed
« Reply #2 on: 17.08. 2018 23:31 »
Set the points gap first, checking both firing positions.

1) Doesn't matter because you can swap leads if it's wrong.
2) Doesn't matter
3) No lead cylinder
4)
5) Yes. See 3.

I believe that the fibre gizmo on the points that runs on the cam ring roughly aligns to the mag connector that will fire.

Online duTch

  • Ricketty Rocketty Golden Flashback
  • Wise & Enlightened
  • *
  • Join Date: Oct 2011
  • Posts: 4518
  • Karma: 40
Re: ignition timing question, help needed
« Reply #3 on: 17.08. 2018 23:40 »

 **GB got in first... *bash*

 Hiya Tony-

 I'm probably not the best for the right answers, as I usually break all the rules...

 1> actually doesn't matter, but I think usually rear to left...
 2> neither fires 'first', as they are at 180˚ to each other, so doesn't matter if you do left or right (I think I usually do the left because it's in my face)
 3>  As above- only need to do one side (one set of points)
 4> done.   *smile*
 5> the points open once in a magneto rev, and twice in..??... Magneto runs same speed as Cam which is half engine speed...
 6>  .......

     Nb;  I usually do it with the points at ~ 5 o'clock....

 It's really not hard, but you need to determine which side is coming up to compression (probably obvious)
 See how you go with that...

Started building in about 1977/8 a on average '52 A10 -built from bits 'n pieces never resto intended -maybe 'personalised'
Have a '74 850T Moto Guzzi since '92-best thing I ever bought doesn't need a kickstart 'cos it bump starts sooooooooo(mostly) easy
Australia

Online BSA_54A10

  • Wise & Enlightened
  • *
  • Join Date: May 2008
  • Posts: 1876
  • Karma: 31
    • BSA National
Re: ignition timing question, help needed
« Reply #4 on: 18.08. 2018 07:59 »
I use a long piston stop, then bring the piston up to the firing position by backing it off while measuring the drop on the other side ( advantage of 360 deg twins ).
This way the engine can not slip while you are tightening up the maggy drive pinion
Bike Beesa
Trevor

Online beezermacc

  • Resident Legend
  • *****
  • Join Date: Dec 2011
  • Posts: 883
  • Karma: 35
  • Not for the purist!
    • Priory Magnetos Ltd.
Re: ignition timing question, help needed
« Reply #5 on: 18.08. 2018 08:04 »
There's a step-by-step guide if you use this link...
https://sites.google.com/site/cheshirebsa/tech-tips
Priory Magnetos Ltd - A10 spares, magneto and dynamo refurbs. www.priorymagnetos.co.uk

Online Rex

  • Valued Contributor
  • ****
  • Join Date: Apr 2017
  • Posts: 474
  • Karma: 1
Re: ignition timing question, help needed
« Reply #6 on: 18.08. 2018 09:14 »
Put her on TDC and unclip the rear mag pickup, look for the brass strip, and if it's there that pickup is for the plug that's sparking. If you follow the workshop manual and have set the timing on the RH pot with points opening at the bottom position, then the rear pickup is for the RH pot.

Offline tonyairconchap

  • Moving Up
  • **
  • Join Date: May 2018
  • Posts: 22
  • Karma: 0
Re: ignition timing question, help needed
« Reply #7 on: 18.08. 2018 09:38 »
Hello All,  many thanks for all the advice.

In the garage first thing this morning,  all done,  1 1/2 hours.   First kick, nothing except for a pop from the exhaust. Swopped over the plug leads, kick and away , tick over good so hopefully road test will prove good.

Thats all three of my BSA back on the road..... wonderful this Tax exempt and no MOT

Will try and load a picture

Thanks again all for your excellent advice and so quickly!

Thanks to TJ Magnetos for the excellent rebuild of the magneto. Highly recommended by me.

Tony

Offline tonyairconchap

  • Moving Up
  • **
  • Join Date: May 2018
  • Posts: 22
  • Karma: 0
Re: ignition timing question, help needed
« Reply #8 on: 18.08. 2018 09:44 »
Couple of pictures of my BSA , i always find it nice to see other peoples bikes
1958 flash
1942 m20
1934 m34/12 sloper


Online Greybeard

  • Jack of all trades; master of none.
  • Wise & Enlightened
  • *
  • Join Date: Feb 2011
  • Posts: 5683
  • Karma: 30
Re: ignition timing question, help needed
« Reply #9 on: 18.08. 2018 10:08 »
Tony,
It's very nice to see your bikes, (you lucky so-and-so!) but it would better to put that picture in the 'Just A Picture' thread of the forum.
https://www.a7a10.net/forum/index.php?topic=7964.0