Author Topic: Blown Fuse  (Read 831 times)

Offline cus

  • Valued Contributor
  • ****
  • Join Date: Jun 2009
  • Posts: 305
  • Karma: 4
Blown Fuse
« on: 10.01. 2010 10:18 »
G'day All,
I've got an in-line fuse on the positive earth between the battery & the frame, it blew a 15a fuse yesterday,
was riding with no lights on. Was a bit out of the blue, so I only had a 20a on me & it blew that the day later.
Looks like I've got a problem somewhere, all wiring is new & probably travelled 1000 miles pretty much trouble
free, any hints on where to start looking.

regards, Cus
56 G/Flash project

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1050
  • Karma: 17
    • www.brightsparkmagnetos.com
Re: Blown Fuse
« Reply #1 on: 10.01. 2010 10:52 »
I'd start with a look at the brake light wiring from battery to switch to rear lamp unit. Especially to see if it's pinched under the rear guard or where it comes through at the back.
Happens often, especially if there's not enough slack for full suspension movement.
Next most likely there's a bare/unplugged connection or a lead detached in the main wire from batt neg to ammeter/switch . . . but then the new fuse would probably have blown straight away (unless it's just a loose end giving an intermittent short).
Always worth also checking the live to the horn is properly insulated and vibe proof, especially if you're not using a relay.

I'd stick yet another fuse in, apply brake light, see what happens and then go from there.
Bill

Offline Josh Cox

  • Valued Contributor
  • ****
  • Join Date: Apr 2009
  • Posts: 275
  • Karma: 0
Re: Blown Fuse
« Reply #2 on: 24.02. 2010 06:35 »
I had the exact same problem, the purple wire to the ammeter had moved around and was rubbing against the mounting bolt on the ammeter.

I'd also check the horn wiring and tail light, perhaps pinched between the tank and frame ?.
Black 1953 Golden Flash Plunger