Author Topic: engine revs up on start up  (Read 982 times)

Offline bsaalf

  • A's Best Friend
  • ***
  • Join Date: May 2009
  • Posts: 43
  • Karma: 0
engine revs up on start up
« on: 15.05. 2010 18:05 »
hi all,
my a10/super rocket has just developed a problem it's been stood up all over the winter since last october and iv'e been starting it up about every 3-4 weeks in the shed and its been fine starting in about 3-4 kicks every time today went to it and it started up fine as usual had it running for a few minutes occasionaly reving it up as you do and sudenly it started missing and backfiring (running rough) then it seemed to clear itself and seemed ok for a few seconds then it stopped, when i started it again it revved up like i was holding the throttle wide open so had to kill the engine quickly thought it was going to explode left it a few minutes tried again and done it again tried it 2 or 3 more times and still the same its as though the throttle is sticking open i did hear a ding which i thought sounded like something falling off the bike and when i looked down i found a small like a shouldered spacer with a slot in it which i think came from the top of the carb where the throttle cable go in its a amal monobloc 389 so i put it back in but it still do the same, anyone got any idea's please regards alf..

Offline MG

  • Resident Legend
  • *****
  • Join Date: Dec 2009
  • Posts: 949
  • Karma: 23
Re: engine revs up on start up
« Reply #1 on: 15.05. 2010 18:39 »
Hi alf!

If the part that fell off looks like the one in the pic, then this is the cable stop that goes on the throttle cable where it enters the twist grip, not on the carb.
It will only fall off if the throttle cable breaks or the slide is sticking, which is probably the case. Take the air filter or bellmouth off and have a look at it.
 
Cheers, Markus
1955 A7 Shooting Star
1956 A10 Golden Flash
1961 Matchless G12 CSR

www.histo-tech.at - Restoration, Repairs, Racing

Austria

Offline bsaalf

  • A's Best Friend
  • ***
  • Join Date: May 2009
  • Posts: 43
  • Karma: 0
Re: engine revs up on start up
« Reply #2 on: 15.05. 2010 18:50 »
thanks markus thats the bit alright i thought it came from the top of the carb, what a idiot i am as ive put it back on the carb end there's nothing else there no adjuster nut then the cable must have been just sitting on top off the carb lid strange any ideas regards alf..

Offline MG

  • Resident Legend
  • *****
  • Join Date: Dec 2009
  • Posts: 949
  • Karma: 23
Re: engine revs up on start up
« Reply #3 on: 15.05. 2010 18:57 »
alf,

there are also carb lids without threads for adjusters, where the cable simply enters through a ferrule. But as far as I can remember these aren't slotted (but can't say for sure at the moment  ???). However, you can never be sure what has been fitted during the years, so the cable stop could also have come off the carb maybe, although it's unlikely I think.
So check the twist grip, maybe it's still there.
1955 A7 Shooting Star
1956 A10 Golden Flash
1961 Matchless G12 CSR

www.histo-tech.at - Restoration, Repairs, Racing

Austria

Offline MikeN

  • A's Best Friend
  • ***
  • Join Date: Mar 2009
  • Posts: 220
  • Karma: 0
Re: engine revs up on start up
« Reply #4 on: 15.05. 2010 21:04 »
Hi alf!


It will only fall off if the throttle cable breaks or the slide is sticking, which is probably the case. Take the air filter or bellmouth off and have a look at it.
 
Cheers, Markus

Or if the cable is sticking and needs lubricating.Or if the cable has got crimped somewhere.
Mike

Offline bsaalf

  • A's Best Friend
  • ***
  • Join Date: May 2009
  • Posts: 43
  • Karma: 0
Re: engine revs up on start up
« Reply #5 on: 15.05. 2010 21:56 »
thanks guy's it did fall out of the handlebar end and the adjustment is also at the handlebar end the cable has two seperate sections the shorter one at the handlebar end with a metal threaded adjuster and locknuts about 8" from the from the twist grip instead off on top of the carb cheer's again regards alf..