Author Topic: A7 oil pump question...  (Read 1139 times)

Offline bikeaholic

  • Moving Up
  • **
  • Join Date: May 2010
  • Posts: 7
  • Karma: 0
A7 oil pump question...
« on: 17.07. 2010 11:36 »
Hi all,
I've just bought a used oil pump for my 1952 A7 Star Twin. My question is, how tight (or loose) should everything be in the assembly? it all seems tight to the point that I can bearly turn the drive cog (the one that meshed with the crankshaft worm drive) by thumb pressure - is this normal, or is this too tight?
I have no idea if this pump was "as is" off a bike or if it has been assembled from parts from other pumps.

Any advice would be appreciated...


Offline Goldy

  • Warwickshire, England
  • Resident Legend
  • *****
  • Join Date: Dec 2008
  • Posts: 619
  • Karma: 9
Re: A7 oil pump question...
« Reply #1 on: 17.07. 2010 13:02 »
 The problem with these pumps is that there are hundreds of them that have been lying around for years and you dont know what people have done to them proviously. You should be able to turn the pump fairly easily by hand, but in any case I would not consider using the pump without dismantling and cleaning. It is easy to dismantle, but it is important to mark each gear, because they need to be re fitted in exactly the same position, I was once told that they should even be fitted into the same gear mesh.  The pump itself is very simple but the problem is wear to the end plate and drive. If the wear is excessive this will allow oil to leak past the end plate or through the drive spindle which will cause a drop in oil pressure and also cause wet sumping which is another story. So dismantle it very very carefuly and see what you have got. all the best.
56 A10 Golden Flash - Restore, ride, relive.                                          
56 C12 BSA project ongoing

Online muskrat

  • Global Moderator
  • Wise & Enlightened
  • **
  • Join Date: Jul 2009
  • Posts: 8176
  • Karma: 106
  • Lake Conjola NSW Oz
    • Shoalhaven Classic Motorcycle Club Inc
Re: A7 oil pump question...
« Reply #2 on: 17.07. 2010 15:02 »
G'day bikeaholic,
                          Goldy is right in all he says. They can be a mongrel to assemble right. If there is wear marks on the end plate or drive boss they need to be lapped on a piece of glass and emery paper (400 grit). On assembly soak all parts in oil and when putting in the screws spin the drive with your thumb.Tighten the screws a little at a time evenly whilst turning the drive. If it starts to bind back off the screws a little a give a few gentle taps with a soft mallet and start again. It may take quite a few goes to get it right, but right it must be.
Cheers
'51 A7 plunger, '57 A7SS now A10CR,  '83 CB1100F, 88 FXST .
Australia
Muskys Plunger A7

Offline MG

  • Resident Legend
  • *****
  • Join Date: Dec 2009
  • Posts: 949
  • Karma: 23
Re: A7 oil pump question...
« Reply #3 on: 17.07. 2010 15:15 »
I found the pump body around the driving cog needs to be cleaned carefully with fine emery cloth after a long time of non-use. Often it is the white zinc-oxide that blocks the cog.

I made up a driving dog that engages with the driven pump gear to drive the pump with the power drill. Thus I run it for quite a time after re-assembly to test it and have everthing bed in after a rebuild (submerged in oil of course!)

Cheers, Markus
1955 A7 Shooting Star
1956 A10 Golden Flash
1961 Matchless G12 CSR

www.histo-tech.at - Restoration, Repairs, Racing

Austria

Online trevinoz

  • Newcastle, N.S.W. Australia.
  • Wise & Enlightened
  • *
  • Join Date: Jul 2006
  • Posts: 2877
  • Karma: 67
Re: A7 oil pump question...
« Reply #4 on: 17.07. 2010 22:45 »
I don't go to the trouble that Musky does, I haven't got the patience.
I lap the marks out and assemble without the drive worm in place and do as Markus does.
After many years, I have never had a failure.
In fact, the only pump I have ever seen fail was on a friend's bike and that was the casting crumbling away with old age leading to catastrophic failure of the pump.
Luckily he found the problem in time and trailered his bike home.

  Trev.

Online bsa-bill

  • Wise & Enlightened
  • *
  • Join Date: Mar 2006
  • Posts: 5415
  • Karma: 61
Re: A7 oil pump question...
« Reply #5 on: 18.07. 2010 08:52 »
first pump I did went very stiff when re-assembled, I had to re-arrange the cogs to find an easier spot but it was still a bit catchy, however it went on like that and has been running fine for the last ten years.
the Pump on the project was much the same ( some people never learn ), the bike was kicked/turned over many times before it was fired up and oil return when running was excellent - full flow, no doubt due to the mount of oil in the sump from squirting it down pushrod tunnel and elswhere.

My guess would be that once the pump is pumping oil it would very soon bed in
All the best - Bill
1961 Flash - stock, reliable, steady, fantastic for shopping
1959 Rocket Gold Flash - blinged and tarted up  would have seizure if taken to  Tesco

Online muskrat

  • Global Moderator
  • Wise & Enlightened
  • **
  • Join Date: Jul 2009
  • Posts: 8176
  • Karma: 106
  • Lake Conjola NSW Oz
    • Shoalhaven Classic Motorcycle Club Inc
Re: A7 oil pump question...
« Reply #6 on: 18.07. 2010 10:20 »
G'day Gents,
                    The reason I spend a bit more time on them is that with a little wear (50-60 years) and are spinning nice when removed they are in their groove. (Hay man) If on re-assembly it is tight it will want to make a new groove (so to speak). Creating more wear and room for oil to escape.
 I think it's one of the most important parts in the motor. The heart pumping the life blood, reducing wear on other most important parts.
Cheers
 I wish I could afford a nice new SRM jobbie.
'51 A7 plunger, '57 A7SS now A10CR,  '83 CB1100F, 88 FXST .
Australia
Muskys Plunger A7