Author Topic: Magneto armature binding  (Read 1839 times)

beesa

  • Guest
Magneto armature binding
« on: 17.09. 2010 09:54 »
Has anybody had experience of the armature binding on the case of a K2f and what did you do to cure it?

The armature rotates but you can hear the rubbing on the stator, I have just replaced the insulating cups on the bearings and I cannot see how to align the armature up with the case,

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1085
  • Karma: 18
    • www.brightsparkmagnetos.com
Re: Magneto armature binding
« Reply #1 on: 17.09. 2010 15:22 »
Hi Beesa and welcome,

If the armature is running eccentrically in the case (and it wasn't before you replaced the insulation washers?) - seems most likely that something's still askew in the bearing or bearing housing department. If the armature's not spinning true, presumably is there a wild difference in points gap between the 2 lobes of the cam ring? In theory, the armature should be carried square on the bearings and their housings and you shouldn't have to do anything special to obtain the basic alignment.
Have you changed the cam-ring housing which carries the cb end bearing  by any chance (that can sometimes introduce error)? Even if you haven't, if you loosen the securing screws for the housing, can you move it such that the rubbing noise goes away?
Is there any noticeable up and down on the bearings - or excessive end-float - as these things could be causing you grief or contributing to it.
In the silly answer department, there isn't a bit of broken HT/earth brush or spring floating around in there is there, causing a jam and / or noise?

If it's none of the above, ie the bearings and housings are good, everything is as it should be, but with pick-ups and sundries detached the armature still touches, then the armature itself might be the culprit. Have you had it apart - eg to change the condenser or something? Because there can be problems regaining perfect alignment end to end. If you have access to a lathe, you can check the armature for true alignment quite easily, also to be sure that one of the iron core pieces isn't standing too proud for some bizarre reason and kissing a magnet as it passes by. But it's not that easy to get it right if it's mis-aligned so hopefully it's simpler than that, and nothing to do with the armature itself.

Good luck anyway, and let us know how you get on!


Bill

beesa

  • Guest
Re: Magneto armature binding
« Reply #2 on: 21.09. 2010 09:34 »
Thanks for the suggestions, I am gradually working thru them, Unfortunatley i did not check to see if the Armature was binding before I dismantled the Magneto. nothing has been changed other than the insulating washers. It has all the original case etc. there is no discearnable end float in the armature. the cam ring housing is a good fit on the body and has no movement sideways when the screws are loosened . i have checked for foreign objects in the armature rotor path and it is completely clear.
the armature has not been disassembled and spinning it in the lathe shows that it is running true. It just leaves the missaligned magnets and i am going to investigate that next. will post the results.

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1085
  • Karma: 18
    • www.brightsparkmagnetos.com
Re: Magneto armature binding
« Reply #3 on: 21.09. 2010 22:23 »
Interesting! If the armature spindle is true (good news) but an iron bit still touches the body/magnets, then I'd say the central bobbin was skewed and that you could maybe true it in the lathe by very lightly removing a few thou. They are quite fragile things when the brass ends are off and it wouldn't take much to put one a bit out of line if someone had had it apart.You're probably a million times better at this stuff than I am (so apologies if it's grannies and eggs), but I'd run the armature between centres and clock the thing from end to end just to be sure that the iron core is as true on the o.d. as the armature is end-to-end.
But before doing that, I agree with you I'd try to see if there was something funny in the body (which is obviously miles harder to measure for the lack of an easy way of getting a good and true centre) - and I don't have any bright ideas short of a major exercise fraught with possibilities (none of them great in an amateur workshop) as to how to get that right! It's not as if the magnets were exactly QD like a wheel. I assume you're happy the drive end bearing housing is concentric and that there hasn't been a past mishap there which is causing today's grief?
What about the points gap variation between cylinders? Presumably there wasn't much to worry about if the armature was straight? Or, if the armature is straight and there's still a significant variation . . . .???
Bill

Offline trevinoz

  • Newcastle, N.S.W. Australia.
  • Wise & Enlightened
  • *
  • Join Date: Jul 2006
  • Posts: 2904
  • Karma: 67
Re: Magneto armature binding
« Reply #4 on: 21.09. 2010 22:37 »
Groily,
              If the armature is out of true it will not cause the point openings to be different from side to side as the points heel will have the same relationship to the case wherever it is.
Point differences are caused by the cam ring or wear in the housing.
Think about it.
Trev.

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1085
  • Karma: 18
    • www.brightsparkmagnetos.com
Re: Magneto armature binding
« Reply #5 on: 22.09. 2010 21:20 »
Agree in principle Trev without having to think too hard, as long as the female/male tapers on the cb end are true. Which is why I only asked the Q as an afterthought, on the basis that things were probably otherwise OK. I'm sure you'd agree that the reasons for differences in gap between cylinders could easily include a not-true cb end shaft and taper, or dodgy cb backplate male taper (just as it could indicate a worn cam ring or an eccentric housing - or a knackered bearing - as you say).
Reverting to the question: a variable points gap could have indicated axial misalignment somewhere, obviously, which might be pause for thought as to what was causing the armature-to-body contact. Apparently the armature's true in this case, which is good.
Maybe you've got a few good thoughts on what could be happening on the inside of the mag body in this case, and what could be done to solve it? I've never yet come across a body with sound and round drive-end bearing housing and good cb end-housing that wouldn't let a true armature pass freely . . .

Bill

Offline trevinoz

  • Newcastle, N.S.W. Australia.
  • Wise & Enlightened
  • *
  • Join Date: Jul 2006
  • Posts: 2904
  • Karma: 67
Re: Magneto armature binding
« Reply #6 on: 22.09. 2010 22:02 »
Groily,
             It doesn't matter if the tapers are skewed or not, if the points plate is offset in one position it will be offset everywhere.
The easiest way to find where the binding is is to remove the armature and have a look.
There will be rub marks.
Another thought is maybe the bearing shimming is too thick.
Trev.

Online groily

  • Wise & Enlightened
  • *
  • Join Date: Jul 2007
  • Posts: 1085
  • Karma: 18
    • www.brightsparkmagnetos.com
Re: Magneto armature binding
« Reply #7 on: 24.09. 2010 22:17 »
You're right Trev - sorry to *** about. The heel on the moving point is going to be doing some work off-centre in such circs and may never be quite the same again I guess, but hey, that's bent for you!

Thinking about this here binding thing again, I was looking up the inside of a couple of K2Fs today and was trying to see how the magnets are positioned and what could be done if, like here apparently, a straight armature in true bearing mounts, properly shimmed, with iron core pieces presumably properly aligned, was hitting anything. And it ain't easy to see. Obviously it's more likely that something on the armature and associated bits and pieces is out of line - but if they're really not off . . .?
The magnetic bits are not something I'd want to think about trying to extract/insert. Do you know how the heck the factory assembled them by any chance? Could they possibly move in some/any circs? If so, can they be shoved square somehow, or would it be safe to machine them up to the axial centre of the case with a boring head or something?
Not that I'd want to do it, but it'd be good to know . . .  in an academic thirst-for-knowledge sort of way!
Bill