Author Topic: charging problem  (Read 1782 times)

Offline emilios

  • Moving Up
  • **
  • Join Date: Apr 2008
  • Posts: 97
  • Karma: 2
charging problem
« on: 22.10. 2010 20:37 »
Hi
I own a BSA a10 plunger 1956..
before few months my lights died...i changed battery but i dont remember how was the privious connected..
posetive earth or negative..
yesterday i got my 2 electronic regulators(negative and positive)cause my problem showed that my old regulator gone bad.
Anyway i polirised dynamo,i charged a new 6v battery and i wired on a new positive earth regulator..
i tyrn on the ligths and ammeter goes to +6,+7..i start engine and i rev and goes to -0,-1..
This happened few times with my old regulator....and after few rides battery gone flat..so its not ammeter wires gone wrong..
I cant tyrn battery terminals other way cause i will distroy the regulator..
So better to change the regulator first(put negative earth)and see if my battery is charging..
Now thats my quetion...from the regulator is getting a red wire that i had to earth it somewhere..could a bad earth connection cause my problem or is just so simple...i have a negative earth wiring?
Thanks
1956 BSA A10 Plunger
1954 BSA B31 Goldstar Replica
1970 Honda cb750K0 project
Cyprus

Online chaterlea25

  • Wise & Enlightened
  • *
  • Join Date: Jun 2009
  • Posts: 3144
  • Karma: 45
Re: charging problem
« Reply #1 on: 22.10. 2010 21:01 »
Hi Emelios,
You can get the ammeter to work correctly by just swopping over the connections on it

+ or - earth can be chosen which ever way you like, the bike does not care, after you polarise the dynamo and the regulator is the one to suit

The best solution for earthing is to run an earthing wires  from ALL the components to a centeral point
(Battery earth bolt??)  run a wire from the headlamp, taillight, dynamo, regulator and battery to this point *ex
*
Hope this helps
John OR
1961 Super Rocket
1963 RGS (ongoing)

Offline emilios

  • Moving Up
  • **
  • Join Date: Apr 2008
  • Posts: 97
  • Karma: 2
Re: charging problem
« Reply #2 on: 22.10. 2010 21:12 »
Hi John
I know that changing the ammeter wires i will see the ammeter working correctly but my battery is still discarge so the ammeter wires show correct..
I will first check the earth wire from regulator and after i will change regulator and earth on battery..
I will let u all know
Thanks
1956 BSA A10 Plunger
1954 BSA B31 Goldstar Replica
1970 Honda cb750K0 project
Cyprus

Online chaterlea25

  • Wise & Enlightened
  • *
  • Join Date: Jun 2009
  • Posts: 3144
  • Karma: 45
Re: charging problem
« Reply #3 on: 22.10. 2010 21:49 »
Hi Emelios,
I think something is being lost in translation???
If you reverse the ammeter the +6  when you turn on the headlamp will go to -6
Then when you  start the engine the -1 will go to +1 *smile*
If you start the engine with the lights off, does the ammeter move ?
leave the lights on for a few minutes to run down the battery a little and then see if it charges?

HTH
John O R
1961 Super Rocket
1963 RGS (ongoing)

Online Triton Thrasher

  • Scotland
  • Wise & Enlightened
  • *
  • Join Date: Feb 2009
  • Posts: 1475
  • Karma: 20
Re: charging problem
« Reply #4 on: 23.10. 2010 08:58 »
If your ammeter shows -6 when you put lights on with engine stopped, the ammeter wires are on the right way round.