Author Topic: Kill Switch won't Kill  (Read 718 times)

Offline cus

  • Valued Contributor
  • ****
  • Join Date: Jun 2009
  • Posts: 305
  • Karma: 4
Kill Switch won't Kill
« on: 17.04. 2011 07:21 »
G'day Everyone,
Have a bit of a minor problem with my '63.
Engine runs & idles well, but when I hit the kill switch it
starts running on one & eventually dies, but takes a while.
First off I tested the switch end by disconnecting the wire
& touching other parts of the frame & bolts, but no improvement,
then unscrewed the end cap off the maggy & checked the pick-up.
All looked OK, but had another one & used a pen spring so there
was good preasure on the centre bolt, same again!, sometimes cuts
out straight away, but more times than not, idles on one.
Don't really no where to look from here.
Haven't got a battery connected at the moment.

regards, Cus
56 G/Flash project

Offline fido

  • Zala County, Hungary
  • Resident Legend
  • *****
  • Join Date: Aug 2006
  • Posts: 684
  • Karma: 8
Re: Kill Switch won't Kill
« Reply #1 on: 17.04. 2011 11:00 »
You could try cleaning the threads on the cap and the mag casing in case you are getting a bad earth connection there.

Offline lawnmowerman

  • Resident Legend
  • *****
  • Join Date: Dec 2009
  • Posts: 619
  • Karma: 8
  • 1959 Super Rocket. Kent, England
Re: Kill Switch won't Kill
« Reply #2 on: 17.04. 2011 21:09 »
Try shorting out the mag end cap terminal to the primary case with a screwdriver (with an insulated handle of course) and see if that stops it. If it does it must be the wiring to the kill switch.

Jim
1959 A10 SR
1938 Wolseley 14/60
1955 Ferguson TEF20 tractor
1965 Ferguson 135 tractor
1952 Matchless G80 rigid
1960 BMW R60
1954 Matchless G80S
1955 Ariel 500 VH
1951 Sunbeam S7DL
1960 Matchless G12 with Watsonian Monza
......and loads of lawnmowers

Too old to Rock and Roll but too young to die  (Jethro Tull 1976)

Online trevinoz

  • Newcastle, N.S.W. Australia.
  • Wise & Enlightened
  • *
  • Join Date: Jul 2006
  • Posts: 2933
  • Karma: 67
Re: Kill Switch won't Kill
« Reply #3 on: 17.04. 2011 23:01 »
Cus,
            Have a look at the earthing brush on top of the magneto.
It could be worn out or missing. [I am presuming you haven't looked there yet.]
Also, the armature may be worn in the brush contact area and burnt on the particular cylinder which won't cut out.
Usually there is a hollow on one side. Apparently it is caused by the polarity of the current on that side.
The cure is to remove the armature and machine it.

  Trev.

Offline cus

  • Valued Contributor
  • ****
  • Join Date: Jun 2009
  • Posts: 305
  • Karma: 4
Re: Kill Switch won't Kill
« Reply #4 on: 18.04. 2011 03:33 »
Hey Trevor,
Your too good! that's what it was,
the mag earth brush.
The spring was compounded in there, so did the old
cut down biro spring & bingo, kills dead!

Thanks, Cus
56 G/Flash project